Skype for Business partial outage
Incident Report for Netstream
Resolved
The issue has been solved
Posted 3 months ago. Jul 18, 2019 - 19:22 CEST
Investigating
We are currently experiencing an outage on our Skype for Business services. We are currently working to identify the issue.
Posted 3 months ago. Jul 18, 2019 - 13:00 CEST
This incident affected: Voice (Skype for Business).