Hosted Exchange outage
Incident Report for Netstream Status
Resolved
The problem has been resolved, Hosted Exchange is available again.
Posted Nov 06, 2019 - 10:27 CET
Investigating
Our Hosted Exchange service is currently experiencing an outage. Email sending and reception might be impaired. We are working on solving the issue.
Posted Nov 06, 2019 - 09:51 CET