Spam Filter Service of Shared Mail Hosting is degraded
Incident Report for Netstream Status
Resolved
This incident has been resolved.
Posted Oct 16, 2018 - 01:35 CEST
Investigating
The Spam Filter Service of Shared Mail Hosting might be affected. We are working on solving the issue.
Posted Oct 11, 2018 - 15:03 CEST