Hosted Exchange mail delivery delayed due to high mail volume
Incident Report for Netstream Status
Resolved
This incident has been resolved.
Posted Oct 18, 2018 - 16:42 CEST
Monitoring
Customers may have experienced delays with mail delivery caused by a high volume of incoming mails.
Posted Oct 18, 2018 - 16:08 CEST